Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Disable scroll
#1
I noticed that v1.9.7 introduced upwards scrolling when a message is printed in the bottom lines of the screen.

Is there a way to disable this? In Ad Lunam, each time something is printed at lines 22-23, and this happens often, the screen scrolls and the information contained in it disappears. This is very annoying  Angry
Reply
#2
mb it will be stupid tip, but use ; after last PRINT
Reply
#3
(11-17-2019, 04:00 PM)Week of the agents Wrote: mb it will be stupid tip, but use ; after last PRINT

I appreciate your try, but honestly, I don't see how that should prevent the screen from scrolling when printing at line 23. And in fact, it doesn't.
Reply
#4
(11-17-2019, 04:31 PM)Alessandro Wrote:
(11-17-2019, 04:00 PM)Week of the agents Wrote: mb it will be stupid tip, but use ; after last PRINT

I appreciate your try, but honestly, I don't see how that should prevent the screen from scrolling when printing at line 23. And in fact, it doesn't.

This is a bug (just tested). It should not scroll.

Sorry, overlooked this message. And has been fixing another (really nasty & hidden) bug.
I will add a -D DISABLE_PRINT_SCROLL flag when compiling so scroll is disabled.
What do you think?
Reply
#5
(11-17-2019, 10:23 PM)boriel Wrote: I will add a -D DISABLE_PRINT_SCROLL flag when compiling so scroll is disabled.
What do you think?

Is it a temporary measure until you correct the bug? All right, as long as it removes that annoying effect  Smile
Reply
#6
For the moment, try downloading this version:
http://www.boriel.com/files/zxb/zxbasic-...-win32.zip
http://www.boriel.com/files/zxb/zxbasic-...ta1.tar.gz
http://www.boriel.com/files/zxb/zxbasic-1.9.9-beta1.zip

Compile with -D DISABLE_SCROLL to disable scroll completely. I will leave this flag even if the scroll is fixed.
Reply
#7
Gracias José, el problema está resuelto... the problem is solved  Smile
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)