Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Compiling with --enable-break behaves different (*solved*)
#1
When I´m compiling this sample.bas from Einar Saukas

Download/Info at: <!-- m --><a class="postlink" href="https://spectrumcomputing.co.uk/index.php?cat=96&id=30005">https://spectrumcomputing.co.uk/index.p ... 6&id=30005</a><!-- m -->
Downloads:
JOY_SourceCode.zip (containing joy.asm) and:
JOY_BorielZXBasicLibrary.zip (containing sample.bas and joy.bas)

with --enable-break the program behaves different to compiling without --enable-break

I´m tested on ZXB v1.7.1 (Windows) as Download-Page for v1.8.0 seems to be not accessible at the moment of writing) and SpecEmu-Emulator.

Screenshot without --enable-break (Please scroll down over Picture to see complete screen)

.png   2018-01-05 15-33-23_SpecEmu.png (Size: 11.18 KB / Downloads: 4,509)

Screenshot with --enable-break (Please scroll down over Picture to see complete screen)

.png   2018-01-05 15-34-21_SpecEmu.png (Size: 10.33 KB / Downloads: 4,507)
Reply
#2
Will test it.
Check you have the latest version 1.8.0 (now it's available) as it fixes some things with -O3 and other code generation.
Which optimization level are you using? -O3?
Reply
#3
I tried with v1.8.0.

I didn´t use the Optimizer-Option.
Now I tested with -O2 and -O3 , but this makes no difference.

Regards,

Luzie
Reply
#4
Okay, I think I've fixed it.
Can you download this 1.8.1-beta version (for windows), and tell me if it works, please? :roll:
Reply
#5
boriel Wrote:Okay, I think I've fixed it.
Can you download this 1.8.1-beta version (for windows), and tell me if it works, please? :roll:
Yes! Bug is gone with v1.8.1-Beta. Compiles and runs OK (even with -O3). Thank you!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)