Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
errors upon compilation
#1
when using the stable version:
/root/Downloads/zxbasic/zxb.py -t -a -B /root/Downloads/zxbasic/examples/colors.bas (in directory: /root/Downloads/zxbasic/examples)
Traceback (most recent call last):
File "/root/Downloads/zxbasic/zxb.py", line 12, in <module>
from six import StringIO
ImportError: No module named six
Compilation failed.


the most recent version of ZXBASIC:
python /root/Downloads/zxbasic/zxb.py -t -a -B /root/Downloads/zxbasic/examples/colors.bas (in directory: /root/Downloads/zxbasic/examples)
Traceback (most recent call last):
File "/root/Downloads/zxbasic/zxb.py", line 14, in <module>
import api.debug
File "/root/Downloads/zxbasic/api/debug.py", line 10, in <module>
from .config import OPTIONS
File "/root/Downloads/zxbasic/api/config.py", line 20, in <module>
from . import global_
File "/root/Downloads/zxbasic/api/global_.py", line 21, in <module>
from .constants import TYPE
File "/root/Downloads/zxbasic/api/constants.py", line 175
NAME_TYPES = {cls.TYPE_NAMES[x]: x for x in cls.TYPE_NAMES}
^
SyntaxError: invalid syntax
Compilation failed.


is it because my version of python is incompatible? its 2.6.4

EDIT -
using python3 works:
python3 /root/Downloads/zxbasic/zxb.py -t -a -B /root/Downloads/zxbasic/examples/colors.bas (in directory: /root/Downloads/zxbasic/examples)
Compilation finished successfully.
Reply
#2
Hi!

Yes, use python 2.7 or python 3.x
I dropped support for python 2.6 long ago!! Actually the next year I'll drop support for python 2 entirely.

Also, if you download the windows version, it already includes a python3 interpreter bundled. :roll: So just running the zxb.exe will do everything for you.
Reply
#3
thanks that works Smile
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)