FAQ  •  Register  •  Login

BiFrost Multicolour engine.

<<

britlion

Posts: 766

Joined: Mon Apr 27, 2009 7:26 pm

Location: Slough, Berkshire, UK

Post Wed Mar 07, 2012 8:09 pm

BiFrost Multicolour engine.

Not my work - but Einar Saukas has been tweaking ZXODUS.

http://www.worldofspectrum.org/forums/s ... hp?t=38179

He's managed to shoehorn it working into ZX Basic too :)
<<

boriel

Site Admin

Posts: 1463

Joined: Wed Nov 01, 2006 6:18 pm

Location: Santa Cruz de Tenerife, Spain

Post Wed Mar 07, 2012 9:20 pm

Re: BiFrost Multicolour engine.

:shock:
....

O_____O

I've already answered. Definitely, I need people like you to directly push changes in the compiler source tree (or at least libraries).
I'm thinking in how could it be done. ZX Basic is already in bitbucket.org (a github repository).
But I feel a "Community Like" site will work better for this: each one could publish his/her own code in his/her own page (like a blog), with code snippers, +1s, a better (really!) wiki with WYSISWYG editr and so on (this is what I asked in the poll).
<<

britlion

Posts: 766

Joined: Mon Apr 27, 2009 7:26 pm

Location: Slough, Berkshire, UK

Post Thu Mar 08, 2012 1:29 am

Re: BiFrost Multicolour engine.

Sicne I appear to have more fun building libraries and writing documentation than writing games to completion (don't ask me why. I have no idea. I keep meaning to finish a big project, and then time gets to me) - I'd probably stick to library functions. But being able to glue those in, and then fix/update them as things go - and have them as a guaranteed base for other functions would be quite useful.
<<

slenkar

Posts: 282

Joined: Sun Feb 13, 2011 3:33 am

Location: Kentucky US, used to be Birmingham UK

Post Mon Jul 16, 2012 1:09 am

Re: BiFrost Multicolour engine.

the latest version has been released, but what has to be done to allow it to be used in boriels basic?
<<

boriel

Site Admin

Posts: 1463

Joined: Wed Nov 01, 2006 6:18 pm

Location: Santa Cruz de Tenerife, Spain

Post Mon Jul 16, 2012 9:53 am

Re: BiFrost Multicolour engine.

slenkar wrote:the latest version has been released, but what has to be done to allow it to be used in boriels basic?

I can help you with that. What do you need?
I'm going to download the lastest version and inspect it, ok?
<<

britlion

Posts: 766

Joined: Mon Apr 27, 2009 7:26 pm

Location: Slough, Berkshire, UK

Post Mon Jul 16, 2012 10:39 am

Re: BiFrost Multicolour engine.

slenkar wrote:the latest version has been released, but what has to be done to allow it to be used in boriels basic?



Einar Saukas said:

"Programmers using the interface libraries (for Boriel's ZX BASIC or z80dk) won't need to do anything at all, it will be enough to download the new interface libraries that I will provide this week."
Last edited by britlion on Mon Sep 02, 2013 12:38 am, edited 1 time in total.
<<

boriel

Site Admin

Posts: 1463

Joined: Wed Nov 01, 2006 6:18 pm

Location: Santa Cruz de Tenerife, Spain

Post Mon Jul 16, 2012 11:32 am

Re: BiFrost Multicolour engine.

I was reading just that. Einar visits this forum, and maintains a library port for ZX BASIC (see demos attached within the zip). ;-)
<<

slenkar

Posts: 282

Joined: Sun Feb 13, 2011 3:33 am

Location: Kentucky US, used to be Birmingham UK

Post Mon Jul 16, 2012 7:48 pm

Re: BiFrost Multicolour engine.

how d'you make pictures and load them in


also when i compile the example i get..

01:01:49 -> bifrost.bas:92: warning: FUNCTION 'BIFROSTfindAttr' declared as FASTCALL with 2 parameters. Compilation failed
01:01:51 -> FAIL: Compiler cannot write output file in directory (Protected Or does Not exist?)

when using BorIDE with Windows Vista

Also when I compile this with the command line

it says 'I FOR without NEXT' on the speccy

it says I have to use this loader

' 10 CLEAR 32767
' 20 LOAD "bifrostdem"CODE
' 30 LOAD "TILES"CODE
' 40 LOAD "BIFROST*"CODE
' 50 RANDOMIZE USR 32768

how do I do this automatically with the emulator?
<<

LCD

Posts: 596

Joined: Fri Feb 13, 2009 3:11 pm

Location: Vienna, Austria

Post Tue Jul 17, 2012 10:02 pm

Re: BiFrost Multicolour engine.

slenkar wrote:how d'you make pictures and load them in


also when i compile the example i get..

01:01:49 -> bifrost.bas:92: warning: FUNCTION 'BIFROSTfindAttr' declared as FASTCALL with 2 parameters. Compilation failed
01:01:51 -> FAIL: Compiler cannot write output file in directory (Protected Or does Not exist?)

when using BorIDE with Windows Vista

Also when I compile this with the command line

it says 'I FOR without NEXT' on the speccy

it says I have to use this loader

' 10 CLEAR 32767
' 20 LOAD "bifrostdem"CODE
' 30 LOAD "TILES"CODE
' 40 LOAD "BIFROST*"CODE
' 50 RANDOMIZE USR 32768

how do I do this automatically with the emulator?

If your output is set to C:/ or system directorys, Vista forbids to write in them unless you start the program in administrator mode. This is meant with "Protected". So check your output directory settings in BorIDE.
Usualy warnings do not cause a compilation fail. Warning fail was possible with earlier version of BorIDE (0.4 r03 or earlier).
where did you set the start of your compiled code? how long is your program? Maybe it crashes with the interrupt handler of BiFrost? Oh, and Clear 32767 do not protects the compiled code.
------------------------------------------------------------
http://lcd-one.da.ru redirector is dead
Visit my http://members.inode.at/838331/index.html home page!
<<

slenkar

Posts: 282

Joined: Sun Feb 13, 2011 3:33 am

Location: Kentucky US, used to be Birmingham UK

Post Tue Jul 17, 2012 10:08 pm

Re: BiFrost Multicolour engine.

I tried moving my project to different places and got the same error, I will try starting it in admin mode next


I didnt set the start of my code, is that the problem?

(does BorIDE allow people to use different loaders?)
<<

LCD

Posts: 596

Joined: Fri Feb 13, 2009 3:11 pm

Location: Vienna, Austria

Post Tue Jul 17, 2012 11:56 pm

Re: BiFrost Multicolour engine.

slenkar wrote:I tried moving my project to different places and got the same error, I will try starting it in admin mode next


I didnt set the start of my code, is that the problem?

(does BorIDE allow people to use different loaders?)

If you did not set the start of code, check what was set by BorIDE.
BorIDE uses only own loaders at the moment, but it is planed to add the possibility to use some custom loaders.

If nothing works, please send me the project files via e-Mail. Maybe I can find out what is wrong.
------------------------------------------------------------
http://lcd-one.da.ru redirector is dead
Visit my http://members.inode.at/838331/index.html home page!
<<

slenkar

Posts: 282

Joined: Sun Feb 13, 2011 3:33 am

Location: Kentucky US, used to be Birmingham UK

Post Wed Jul 18, 2012 3:40 am

Re: BiFrost Multicolour engine.

i havent had access to my boriel PC yet, please download the bifrost engine here:

ftp://ftp.worldofspectrum.org/pub/sincl ... erface.zip

then just try to compile the bifrostdem.bas
<<

LCD

Posts: 596

Joined: Fri Feb 13, 2009 3:11 pm

Location: Vienna, Austria

Post Wed Jul 18, 2012 6:52 pm

Re: BiFrost Multicolour engine.

Have you defined a output file? I just defined it and got:
  Code:
20:46:12 -> bifrost.bas:92: warning: FUNCTION 'BIFROSTfindAttr' declared as FASTCALL with 2 parameters. Compilation successfull
20:46:12 -> Compilation time: 4509ms

If there is no output file defined, the compilation will fail. By default no file is defined.
------------------------------------------------------------
http://lcd-one.da.ru redirector is dead
Visit my http://members.inode.at/838331/index.html home page!
<<

slenkar

Posts: 282

Joined: Sun Feb 13, 2011 3:33 am

Location: Kentucky US, used to be Birmingham UK

Post Wed Jul 18, 2012 6:58 pm

Re: BiFrost Multicolour engine.

OK I ran BorIDE in admin mode on windows vista

then it gets a little further:
14:56:07 -> Compilation starts(60 Lines)
14:56:07 -> Source C:\Dropbox\specprojs\bifrost\bifrostdem saved
14:56:07 -> C:\Program Files\Boriel Tm\ZX Basic Compiler\zxb.exe "C:\Dropbox\specprojs\bifrost\temp.bor" -S 24576 -o "output.bin" --heap-size=1000

14:56:10 -> Exit code: 0
14:56:10 -> bifrost.bas:92: warning: FUNCTION 'BIFROSTfindAttr' declared as FASTCALL with 2 parameters. Compilation successfull
14:56:10 -> FAIL: Compiler cannot write output file in directory (Protected Or does Not exist?)
14:56:10 -> Compilation time: 2542ms
"C:\Dropbox\specprojs\wars\EmuZWin26\EmuZWin.exe" "output.tzx"

how do i set the output file?
I saw something on the right that says 'output' so I chose TZX

I right-clicked on the folder and it said it was 'read-only' I tried to change it back which it does.
Then when I right-click on the folder again it says 'read-only' again!

On the microsoft website they even have a command-line thing which doesnt work either:
'attrib -r c:\specprojs'

I think you have to insert some code into BorIDE to make it ask for full admin control when it starts.




When compiling from the command line I tried adding these 2 lines to replace the loader

10 CLEAR 32767
15 RANDOMIZE 32768

or

10 CLEAR 32767
15 RANDOMIZE USR 32768

but it complains about randomize
Last edited by slenkar on Wed Jul 18, 2012 7:41 pm, edited 1 time in total.
<<

LCD

Posts: 596

Joined: Fri Feb 13, 2009 3:11 pm

Location: Vienna, Austria

Post Wed Jul 18, 2012 7:41 pm

Re: BiFrost Multicolour engine.

Please use at moment TAP for output. TZX does not write Files in this version yet.
Edit: TZX will be added in the next release.
Last edited by LCD on Wed Jul 18, 2012 9:21 pm, edited 3 times in total.
------------------------------------------------------------
http://lcd-one.da.ru redirector is dead
Visit my http://members.inode.at/838331/index.html home page!
Next

Return to ZX Basic Compiler

Who is online

Users browsing this forum: No registered users and 1 guest

cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by Vjacheslav Trushkin for Free Forums/DivisionCore.

phpBB SEO